[ANN] Gradle 0.1.2 is released

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[ANN] Gradle 0.1.2 is released

hans_d
Administrator
We have done a couple of bug fixes and improvements. 

We have the changed the default logging behavior. Ivy is now default (you can switch it to error level via -i)
There is one breaking change. The addIBiblio method of dependencies has been renamed to addMavenRepo. There is also a new version of the user's guide.

Release Notes - Gradle - Version 0.1.2

** Bug    * [GRADLE-48] - Failing integ test under windows leads to consol exit if started via gradlew    * [GRADLE-58] - Windows console closed on build failure    * [GRADLE-63] - Modify header of *nix gradle script
** Improvement    * [GRADLE-41] - Offer a flag to control whether the build should stop when Ivy can't find a dependency.    * [GRADLE-61] - Rename addIBiblio to addMavenRepo    * [GRADLE-65] - Make ivy info log level the default

--
Hans Dockter
Gradle Project lead




Reply | Threaded
Open this post in threaded view
|

Re: [gradle-user] [ANN] Gradle 0.1.2 is released

Russel Winder-2
Hans,

On Thu, 2008-04-24 at 16:58 +0200, Hans Dockter wrote:
> We have done a couple of bug fixes and improvements.

> We have the changed the default logging behavior. Ivy is now default
> (you can switch it to error level via -i)
> There is one breaking change. The addIBiblio method of dependencies
> has been renamed to addMavenRepo. There is also a new version of the
> user's guide.

Sorry for raising that one, but it was irritating me :-)

> Release Notes - Gradle - Version 0.1.2
>
> ** Bug    * [GRADLE-48] - Failing integ test under windows leads to
> consol exit if started via gradlew    * [GRADLE-58] - Windows console
> closed on build failure    * [GRADLE-63] - Modify header of *nix
> gradle script
> ** Improvement    * [GRADLE-41] - Offer a flag to control whether the
> build should stop when Ivy can't find a dependency.    * [GRADLE-61] -
> Rename addIBiblio to addMavenRepo    * [GRADLE-65] - Make ivy info log
> level the default
I'm going to be annoying:  I am already irritated by having to download
and install a new version of Gradle.  I really would like to execute
Gradle straight from a Subversion checkout or have a way of installing
Gradle easily from the Subversion checkout.

For SCons there is a bootstrap script which can be used to execute SCons
direct from the Subversion store, this makes working with the latest
version trivial.  For Gant there is a very simple bootstrap install so
working from the Subversion store (or in my case Git or Bazaar store as
I am increasing dissatisfied with Subversion) just requires "ant
install".

So what I need is the instructions for using Gradle from the Subversion
store -- I am guessing this is more like SCons that Gant in this respect
as Gradle carries all it needs in the repository, it just needs a
configuration step.  I guess this is very analogous to Grails where
there is an Ant target to set up a checked out repository to be a usable
installation.

Thanks.
 
--
Russel.
====================================================
Dr Russel Winder                 Partner

Concertant LLP                   t: +44 20 7585 2200, +44 20 7193 9203
41 Buckmaster Road,              f: +44 8700 516 084
London SW11 1EN, UK.             m: +44 7770 465 077

signature.asc (196 bytes) Download Attachment