Correct syntax of "linked" attribute in "xref" elements?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Correct syntax of "linked" attribute in "xref" elements?

KARR, DAVID
The User Guide has many "xref" elements with a "linkend" attribute.  In almost all cases, these appear to work fine.  The ones which reference an id value within the set of documents seem to all work fine.  There is only one in the entire document tree where the "linkend" attribute is a URL an external page, not a reference to a page within the tree.  This particular one is rendering "???" in the PDF.

For instance, here is one of the many that appears to work fine:
------------------
            <para><xref linkend="sec:build_phases"/> describes the phases of every Gradle build.
------------------

Here is the one that is rendering "???":
----------------------------
                See <xref linkend="http://www.gradle.org/docs/current/userguide/tutorial_this_and_that.html#sec:configuring_using_external_script"/> for more information.
----------------------------

I've verified that this URL is valid and exists.  I imagine that "linkend" isn't the correct attribute to use for a URL.  What should be done here?

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Correct syntax of "linked" attribute in "xref" elements?

Luke Daley-2


On 20 July 2014 at 9:10:50 am, KARR, DAVID ([hidden email]) wrote:

The User Guide has many "xref" elements with a "linkend" attribute. In almost all cases, these appear to work fine. The ones which reference an id value within the set of documents seem to all work fine. There is only one in the entire document tree where the "linkend" attribute is a URL an external page, not a reference to a page within the tree. This particular one is rendering "???" in the PDF. 

For instance, here is one of the many that appears to work fine: 
------------------ 
<para><xref linkend="sec:build_phases"/> describes the phases of every Gradle build. 
------------------ 

Here is the one that is rendering "???": 
---------------------------- 
See <xref linkend="http://www.gradle.org/docs/current/userguide/tutorial_this_and_that.html#sec:configuring_using_external_script"/> for more information. 
---------------------------- 

I've verified that this URL is valid and exists. I imagine that "linkend" isn't the correct attribute to use for a URL. What should be done here? 

The ‘linkend’ should be sec:configuring_using_external_script.