Weird warning message

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Weird warning message

Russel Winder-2
I am using a Bazaar branch and/or Git repository taken from Subversion
Trunk HEAD of Gradle and kept up to date, so right on the bleeding
edge :-)  Every invocation of Gradle gives me:

DEPRECATED: allownomd is deprecated, please use descriptor="optional"
instead

which is fine in that I am on the bleeding edge and so should expect
such messages.  On the other hand I have no idea how to stop it!

--
Russel.
====================================================
Dr Russel Winder                 Partner

Concertant LLP                   t: +44 20 7585 2200, +44 20 7193 9203
41 Buckmaster Road,              f: +44 8700 516 084
London SW11 1EN, UK.             m: +44 7770 465 077

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Weird warning message

hans_d
Administrator

On Oct 6, 2008, at 10:48 AM, Russel Winder wrote:

> I am using a Bazaar branch and/or Git repository taken from Subversion
> Trunk HEAD of Gradle and kept up to date, so right on the bleeding
> edge :-)  Every invocation of Gradle gives me:
>
> DEPRECATED: allownomd is deprecated, please use descriptor="optional"
> instead
>
> which is fine in that I am on the bleeding edge and so should expect
> such messages.  On the other hand I have no idea how to stop it!

This is due to a last minute change in the Ivy RC1 where they  
deprecated one method Gradle is using internally. We will fix this soon.

Thanks for pointing this out.

- Hans

--
Hans Dockter
Gradle Project lead
http://www.gradle.org





---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email